Huawei E5830 / E5832S / E585 / E586 und MultiSim + Update für neue Huawei Geräte

Update: Befehl für neuere Geräte wie E589, E5776, E5372 eingefügt. Vielen Dank an die Tipps der Kommentargeber!

Wer eine T-Mobile Multi-Sim in seinem Huawei E5 (trifft auf alle Modelle zu) benutzt, hat das Problem, dass er telefonisch nicht mehr erreichbar ist. Es kommt ein Besetztzeichen oder es klingelt nur einmal und das wars.

Warum ist dies so? Kurz zum Hintergrund:

Für die Mobilfunktechnik gibt es zwei verschiedene Netzmodi. Einmal den CS und zweitens den PS Modus. CS = Circuit Switching (Anrufe und Daten) im Vergleich zu PS = Packet Switching (nur Daten).
Im PS Modus können z.B. keine SMS empfangen werden, was das E5830 sowie E585/586 ja erlaubt. Standardmäßig wird also immer versucht, CS+PS zu aktivieren.

Gibt es nun mehrere SIM Karten für eine Nummer, kann folgendes helfen:

  1. Eine Priorisierung der SIMs, so dass z.B. die Daten-Sim nicht die erste Priorität hat und Anrufe nicht standardmäßig an dieser SIM-Karte ankommen.
  2. Eine Aktivierung der SIM als reine Datensim, die nur den PS Modus erlaubt. Diese beiden Optionen sind bei vielen Netzanbietern ohne Probleme möglich, mit der MultiSim von T-Mobile ist dies Stand heute nicht möglich. Die Hotline blockt hier leider ab.

Alternativ gibt es folgende Möglichkeit, das E5830, E5832S, E585 und E586 dauerhaft auf „PS only“ umzustellen:

  1. Bitte das Gerät an einen Windows PC anschließen, die Treibersoftware installieren bzw. diese muss installiert sein.
  2. Dann das Hyperterminal (gibt es unter Start->Zubehör) starten.
  3. Es sollte dort dann zwei Huawei COM Ports zur Auswahl geben.
  4. Beim Nutzen des Hyperterminals bitte das “UI Interface” bzw. dessen COM Port verwenden.
  5. Folgender Befehl schafft dann Abhilfe: AT^SYSCFG=2,2,3FFFFFFF,1,1
    Achtung:
    Neuere Geräte ab E589, also E5776, E5372 etc. benötigen folgenden Befehl: AT^SYSCFGEX=”00″,3FFFFFFF,1,1,7FFFFFFFFFFFFFFF,,
    (bitte auch die beiden Kommas am Ende mit einfügen)
  6. Kopieren und Einfügen funktioniert meistens nicht, von daher manuell eingeben und danach Enter drücken. Dann etwas länger warten, bis die Antwort kommt (kann bis zu einer Minute dauern).

Wichtig: Die Eingabe erfolgt blind, man sieht also nicht was eingegeben wurde.
Daher die Kombination mit extremer Sorgfalt eingeben.

Falls kein OK zurückkommt, das Ganze nochmal versuchen, also das Hyperterminal neustarten. Sobald nach dem Befehl einmal ein OK gekommen ist, ist die Einstellung dauerhaft im Gerät gespeichert.

Im Webinterface unter „Einstellungen“->“System“->“Diagnose“ sollte dann nur „PSD fähig“ und nicht mehr „CSD & PSD fähig“ stehen, dann hat die Einstellung geklappt und ist auch dauerhaft gespeichert.

Unter Windows 7 gibt es kein Hpyerterminal mehr, daher eignet sich folgendes:
http://www.attachmate.com/Products/Terminal+Emulation/reflection14/ruo/ruo.htm

Kann evtl. einfacher sein da Hyperterminal gerne einmal „zickig“ ist und lange nicht reagiert.

Update Januar 2013: Um wieder den Kombimodus aus CS+PS zu aktivierne, muss die letzte „1“ auf eine „2“ geändert werden: AT^SYSCFG=2,2,3FFFFFFF,1,2

42 Kommentare zu „Huawei E5830 / E5832S / E585 / E586 und MultiSim + Update für neue Huawei Geräte“

  • Tom:

    Wirklich Nice! i like it! Wo ist denn der Facebook-Like-Button?

  • Sehr, sehr gut erklärt, vielen Dank!

  • Vielen Dank – Einfach zu verstehen und erfolgreich in der Anwendung. Bei mir hat es 100% funktioniert.

  • Troll:

    Klasse! Vielen Dank :) Das „Dach“ Zeichen war nicht so einfach zu finden. Mit doppelt drücken hat es dann geklappt :)

  • Name Michael:

    Kennt sich jemand mit Attachmate aus? Ich hab da echt keinen Plan, wie ich nun zu dem Terminalfenster komme, das Prigramm verlangt nach Hostnamen/IP-Adresse

  • Michael B.:

    Vielen Dank für den Tipp. Unter Windows 7 hab ich unter http://www.hilgraeve.com/hyperterminal/ das passende Programm „Hyper Terminal Private Edition“ gefunden, da hat es sogar mit Kopieren – Einfügen sofort funktioniert.

  • Christoph:

    Vielen Dank, das hat mir sehr geholfen! (Auch mit einer Multisim von t-mobile)
    Bei mir hat auch das Kopieren/Einfügen im Hyperterminal von Windows XP funktioniert.

  • Name Michael:

    Hallo,
    danke für den Tipp mit „Hyperterminal Private Edition“, hat geklappt.

  • Uli:

    Unter OSX hat es in einen Terminalfenster mit
    $ sudo screen /dev/tty.HUAWEIMobile-Pcui
    und dann den Befehl in das Terminal hineinkopieren und anschließendem return geklappt.
    Danke für den Tipp!

  • cm:

    hervorragend, Gruss CM

  • Frank:

    Kann man das auch wieder rückgängig machen, Zeichenfolge?

  • admin:

    Um dies wieder Rückgängig zu machen, muss die letzte „1“ auf eine „2“ geändert werden:

    AT^SYSCFG=2,2,3FFFFFFF,1,2

  • iza.c:

    hallo gentlemans

    bestimmt sind hier ungefahrene frauen ungern gesehen … nun ich werde mich freuen wenn ihr mir hilft, diese prioriesierung bei huawei e589 und multisim umzustellen… nun ich brauche anleitung „step by step“

    ich kaempfe mit telekom seit 8 wochen .. und jedes mal hoere … dass esnicht moeglich ist ..

    gerne werde mich auch fuer die hilfe entsprechend bedanken …

    thanks , iza

  • hat mich Nerven ohne Ende gekostet (unterW7)aber jetzt gehts, ist das nicht toll :-)

  • Michael Huettlin:

    Gibt es einen anderen Befehlssatz für die Huawei E5776S-32 original Telekom?
    Denn wenn ich disen Befehlssatz eingebe, akzeptiert die Speedbox LTE die Eingabe, meldet sich aber nur im 3G an. LTE wird zumindest nicht angezeigt… Nach reset zeigt die Speedbox LTE auch wieder LTE im Display!

  • EsKalation:

    Kann mir bitte nochmal jemand eine Anleitung geben, wie ich mit dem Hyperterminal auf das Modem connecte? Welchen Com-Port muss ich nutzen? Mein Hyperterminal stürzt immer ab, wenn ich versuche, eine Verbindung herzustellen.

  • DANSI:

    Hallo für den Huawei e589 gilt das SYSCFG – Kommando nicht.

    Dafür gibts aber jetzt das SYSCFGEX – Kommando.

    Achtung die Parameter sind nichtmehr die selben. Jedoch lässt sich der CS und PS Mode umschalten.
    PS-Mode: AT^SYSCFGEX=“00″,3FFFFFFF,1,1,7FFFFFFFFFFFFFFF,,
    CS_PS-Mode: AT^SYSCFGEX=“00″,3FFFFFFF,1,2,7FFFFFFFFFFFFFFF,,
    Die beiden Kommas am Ende nicht vergessen.

    Mehr Infos zu SYSCFGEX:
    ^SYSCFGEX:(list of supported s),
    (list of supported( ,)s),
    (list of supported s),
    (list of supported s),
    (list of supported( ,)s)

    “00” Automatic search
    “01” GSM
    “02” WCDMA
    “03” LTE
    “04” CDMA
    “05” TD-SCDMA
    “06” Wimax
    “99” No change

    00080000 (CM_BAND_PREF_GSM_850) GSM 850
    00000080(CM_BAND_PREF_GSM_DCS_1800) GSM DCS systems
    00000100(CM_BAND_PREF_GSM_EGSM_900) Extended GSM 900
    00000200(CM_BAND_PREF_GSM_PGSM_900) Primary GSM 900
    00100000(CM_BAND_PREF_GSM_RGSM_900) Railway GSM 900
    00200000(CM_BAND_PREF_GSM_PCS_1900) GSM PCS
    00400000(CM_BAND_PREF_WCDMA_I_IMT_2000) WCDMA IMT 2000
    00800000 (CM_BAND_PREF_WCDMA_II_PCS_1900) WCDMA_II_PCS_1900
    04000000 (CM_BAND_PREF_WCDMA_V_850) WCDMA_V_850
    0002000000000000 (CM_BAND_PREF_WCDMA_VIII_900) WCDMA_VIII_900
    3FFFFFFF <– Standardeinstellung?

    Roaming support:
    0 Not supported
    1 Roaming is supported
    2 No change
    domain setting:
    0 CS_ONLY
    1 PS_ONLY
    2 CS_PS
    3 ANY
    4 No change

    1 ((CM_BAND_PREF_LTE_EUTRAN_BAND1) LTE BC1
    40((CM_BAND_PREF_LTE_EUTRAN_BAND7) LTE BC7
    2000(CM_BAND_PREF_LTE_EUTRAN_BAND13) LTE BC13
    20000(CM_BAND_PREF_LTE_EUTRAN_BAND17) LTE BC17
    10000000000(CM_BAND_PREF_LTE_EUTRAN_BAND40) LTE BC40
    7FFFFFFFFFFFFFFF <– Standardeinstellung?

    Grüße DANSI

  • iza.c:

    hallo … ich habe schon im Februar gepostet und naach hilfe gefragt …
    leider habe alle mir ekannten trics und tipps und und ausprobiert…
    auch kurze program geschrieben und das geraet geöffnet
    Hat leider nicht geklappt :(

    kann mir bitte jemand Helfen bei e589 die priorisierung umstellen???

    gruß
    iza

  • heureka:

    Vielen Dank für die Tipps: Ich habe es mit einem E585 wie von Uli beschrieben sogar auf einem Mac OSX10.8.5 hinbekommen. Ich musste nur vorher die Treiber direkt vom internen Speicher des Gerätes installieren. Und das Gerät muss natürlich an sein: PocketWifi_Driver.app

    Bei einem anderen Gerät vom Typ Huawei E5832, klappte es übrigens nicht ! Weder mit Mac, noch Win7 oder XP ließ sich trotz erfolgreicher Terminal Verbindung ein Befehl absetzen. Das 5832 meldet auch einen ganz anderen Port im Terminal, der Die Ports lassen sich im Mac-Terminal mit dem folgenden Befehl auslesen:
    ls /dev/tty.*

    Das 5832 hat den Port: /dev/tty.HUAWEIMobile-Diag
    Das E585 hat den Port: /dev/tty.HUAWEIMobile-Pcui

    Also mit dem E5832 gehts offensichtlich nicht.

    Besten Gruß,
    heureka

  • alex2686:

    Hallo, ich habe das Problem mit dem e5776 von huawei.
    Die terminal befehle funktionieren nicht, jemand eine idee?

  • Matthias:

    Hallo, entschuldigt wenn ich diesen „alten“ Beitrag wiederbelebe…
    Ich versuche gerade meinen Huawei e5220 auf „PS only“ umzustellen, leider ohne Erfolg. Die hier beschriebenen AT-Befehle funktionieren nicht (keine Überraschung, denn der e5220 ist hier ja auch nicht aufgeführt). Weiss jemand ob es möglich ist den e5220 umzustellen, und wenn ja, wie?

    VG
    Matthias

  • R205:

    Bei dem E589 geht das leider nicht, da es nicht als USB Modem funktioniert.

    Für die Jüngeren, die ohne Modem und Hayes Befehlssatz aufgewachsen sind: Mit ATE1 sieht man auch seine Eingaben im Terminal 😉

  • R205:

    Geht doch mit dem E589 wenn man die Huawei Drivers (4.25.18) unter Windows verwendet. Dann kann man wie oben beschrieben mit einem Terminal das Modem konfigurieren. Allerdings ist die Syntax etwas anders.

    at^SYSCFGEX=“00″,3FFFFFFF,1,1,7FFFFFFFFFFFFFFF,,

    Die zwei Kommas am Ende sind wichtig, sonst bekommt man eine Fehlermeldung

    Die zweite „1“ steht für das Paketswitching only. Zum zurücksetzten muss da also wieder eine 2 rein.

    at^SYSCFGEX=“00″,3FFFFFFF,1,2,7FFFFFFFFFFFFFFF,,

    Mit at^CURC=0 kann man übrigens die lästigen Meldungen ausschalten, wenn man das Modem konfiguriert.

  • Oberon:

    Guten Tag,

    hier noch eine wichtige Anmerkung für neuere Geräte – z.B. huawei e589u-12 : Diese unterstützen teilweise den genannten Befehl AT^SYSCFG nicht. Als Äquivalent ist hier der Befehl AT^SYSCFGEX zu benutzen. Die komplette Syntax lautet

    AT^SYSCFGEX=“00″,3FFFFFFF,2,1,7FFFFFFFFFFFFFFF,,

    Ein detaillierte Erklärung der Parameter ist unter http://www.net139.com/UploadFile/menu/HUAWEI%20UMTS%20Datacard%20Modem%20AT%20Command%20Interface%20Specification_V2.3.pdf

    ————

    Dear all,

    some of the newer devices, e.g. e589u-12 do not support the mentioned AT^SYSCFG command.

    One should use AT^SYSCFGEX with a slightly different syntax instead:

    AT^SYSCFGEX=“00″,3FFFFFFF,2,1,7FFFFFFFFFFFFFFF,,

    More details per parameter are available under the link provided above.

    Best Regards

  • sh:

    Hallo zusammen,
    beim E5372 und Firmware 21.270.09.00.00 erhalte ich trotz Copy&Paste bei Eingabe von AT^SYSCFGEX=”00″,3FFFFFFF,1,1,7FFFFFFFFFFFFFFF,, die Meldung „+ CME Error: 50“. Woran kann das liegen?

  • rd:

    Kann mir jemand helfen? Wie ist es beim E5331. Leider funtktioniert das auch nicht mit einer Multisim.

    Danke

  • sj:

    Hi,
    vielen dank für die Anleitung! Beim E5372 hat es bei mir mit AT^SYSCFG=2,2,3FFFFFFF,1,1 („alter“ Befehl) funktioniert :-)

  • JB:

    Für den Mobile Huawei E5756s-2 hat der folgende Code funktioniert

    AT^SYSCFG=2,2,3FFFFFFF,1,1 (ohne doppeltes Komma!!!)

  • sff:

    Bei mir hats mit dem E5372 auch mit folgendem Befehl geklappt:
    AT^SYSCFG=2,2,3FFFFFFF,1,1

  • MR:

    Bin auch eben mit dem alten (??) Befehl erfolgreich gewesen (E5372):
    AT^SYSCFG=2,2,3FFFFFFF,1,1

    Vielen Dank für die Infos.

  • DD:

    Vielen Dank! Hat mir sehr geholfen. Der Stick E3531 funktioniert bestens.
    Befehl: AT^SYSCFG=2,2,3FFFFFFF,1,1

  • […] for that issue, I found that it is possible to deactivate this behavior by sending a special AT-sequence to the […]

  • hansiii:

    Vielen Dank!
    Huawei E5330 geht auch!

    Huawei E8231 ist etwas Triky!

    Das Huawei E8231 meldet sich im Windows mit einem „Remote NDIS based Internet Sharing Device“ das ist ja kein Modem somit kann man die geliebten AT befehle nicht über ein Terminal Programm absetzten. Wenn man den Stick am Notebook dran hat und sich auf der Webseite des „Routers“ angemeldet hat einfach in der Adresszeile des Browser http://192.168.8.1/html/switchProjectMode.html [IP sollte eurem Huawei entsprechen] eingeben. Danach installieren sich zwei unbekannte Geräte. Für diese Geräte muss man dann noch die Treiber einbinden. Und schon geht es auch mit Modems.

    Leider muss man die HWIDs in die ewser2k.inf eintragen damit man diese Treiber dann installieren kann muss man bei Windows 8 die Treibersignierung abschalten.

    Grüße
    Hansiii

  • blubbabloedi:

    Hansiii, wie hast du es für den e5330 gelöst bekommen?

  • hansiii:

    @blubbabloedi

    Per usb angeschlossen.
    Verbindung mit Internet trennen über die Webseite des Huawei z.b.
    dann mit MWCONN Config.exe unter Gerat Gerätetyp Huawei ausgewählt.
    Der COM Port sollte von alleine gefunden werden kannst du ja Prüfen im
    Gerätemanager.
    Und dann einfach „AT^SYSCFG=2,2,3FFFFFFF,1,1“
    bei dem Feld „Hier klicken für Konsolen-Eingaben“ eingeben.

    Bei der Servicekonsole sollte dann ein Ok kommen.
    Da die Verbindung dann aber auf ist schreibt er fröhlich weitere Daten in dem Fenster weiter.

    Gruß
    Hansiii

  • Dani:

    Hallo Hansiii,

    leider schlägt die automatische Port erkennung bei mir fehl mir der Medlung:
    * Der Port konnte nicht
    automatisch ermittelt werden.

    im Geräte Manager wird der Huawei e5330 unter Netzwerkadapter – Remote NDIS based Internet Sharing Device erkannt.

    Unter den Eigenschaften finde ich leider den Port nicht heraus.
    Als Geräte Ort steht dort Port_#0005.Hub_#0004.

    Hast du einen noch einen Tip für mich ? :)

    Vielen Dank

  • Dani:

    Hallo nochmal,

    also ich habe nun die ganze Nacht gesucht und gesucht. Bekomme die Verbindung über MWCONN nicht hergestellt.

    hier ein paar Fakten :
    Ich habe mir den Huawei Mobile Wifi E5330 gekauft. Wenn ich dort meine Multisim der Telekom einlege ist ein Anrufen auf meinem Handy nicht mehr möglich…. ist ja soweit bekannt.

    Ich benutze Windows 7 64 BIT. Wenn ich das Huawei über USB mit meinem PC verbinde, installiert er direkt einen Treiber. Ein Zugreifen auf den Internen Speicher ist nicht möglich bzw. wird im Arbeitsplatz garnicht angezeigt. Auch nicht wärend der Installation des Treibers.
    Als installierter Treiber im Geräte Manager finde ich:
    “Remote NDIS based Internet Sharing Device”
    eine Eingabe im Browser als http://192.168.8.1/html/switchProjectMode.html
    wie es oben bereits beschrieben hattest führt leider nicht zum Erfolg. Wenn ich diese Seite Aufrufe lande ich wieder auf der klassischen Home Ansicht des Huawei´s.
    Mitlerweile wurde mir klar, dass der PC den Port im MWCONN nicht erkennen kann solange der Treiber als „Remote NDIS based Internet Sharing Device“ installiert ist, da ein austausch als AT Modem Befehl nur über einen „COM“ Anschluss mit konfiguriertem Modem möglich ist.

    Bin leicht am Verzweifeln.

    Hoffe irgendwer ließt hier überhaupt bei diesem „alten“ aber für mich brand aktuellen Artikel noch mit 😀

    Schönes Wochenende ! Daniel

  • hansiii:

    HI Dani,

    komisch mein E5330 hatte sofort COM Ports sobald ich ihn mit USB Kabel angebunden hatte.
    Wenn Du die switchProjectMode.html Seite aufrufst hattest Du vorher dich auch einer anderen Seite des „Routers“ mal mit deiner Admin Kennung angemeldet?
    Bin ich auch beim ersten mal darübergestolpert.

    Hoffe du bekommst es hin, hatte genau das gleiche Problem mit der Multisim der Telekom.

    Grüße
    Hansiii

  • Dani:

    Hallo,

    vielen Dank nochmal für die Hilfen. Leider habe ich es mit dem E5330 nicht hinbekommen. Keine Chance das Gerät zur Installation von Com-Ports zu bewegen. Weder mit Windows noch mit MAC.

    Habe mir nun den Huawei E586E gekauft. Da hat alles von Anfang an wie beschrieben funktioniert :-D.

    Problem also gelöst !

    Danke. Schönes Wochenende

  • Marc:

    Hallo zusammen,

    ich habe einen Huawei E5170S. Leider habe ich genau das gleiche Problem. Funktioniert es hier ebenfalls einen solchen AT Command abzusenden?
    Ich hab gesehen, dass das Gerät einen USB Anschluss hat, über den das Dock angeschlossen wird. Demnach müsste ich ein USB Kabel haben was zweimal einen Anschluss hat wied er der in den PC geht. Kann das funktionieren?
    Danke und Gruß

  • […] Mir ist aufgefallen, dass bei Nutzung des E8231 mit Multi-SIM keine Anrufe mehr aufs Handy durchkommen. Folgende Seite könnte Abhilfe schaffen: http://blog.wlan-unterwegs.de/…/ […]

Leave a Reply

*